Page 1 of 1

SH-550 acoustic pickup jack nonfunctional

Posted: Mon Oct 02, 2017 8:38 pm
by CalHusker
I have an SH-550 with the acoustic option and it has two jacks for output. One is silver and one is black colored.

One jack gives everything = full electric pickups, acoustic and electric pickups together, and just acoustic pickups

The other output jack on the guitar does nothing.

I have checked the battery and it is new. I took the cover off the back and there are wires going to this jack

I have the acoustic pickup in the bridge (I assume) is it related to that. There are 2 balck wires going to this nonfunctional jack.

Any help will be appreciated....The thing plays like a dream....

Re: SH-550 acoustic pickup jack nonfunctional

Posted: Mon Oct 02, 2017 9:55 pm
by spudmunkey
One of the jacks does both... but i think the other one only comes on if there are cables plugged into both, if i remember right.

Like... you use the one that legs yhiu blend the signal unless you have a house pa or acoustic amp to plug into. Then you plug in the second and it splits off the piezo acoustic signal to the 2nd cable.

Re: SH-550 acoustic pickup jack nonfunctional

Posted: Tue Oct 03, 2017 6:41 am
by CalHusker
Now there is something I did not try.....I will get on it and give it a try....Thank you!

Re: SH-550 acoustic pickup jack nonfunctional

Posted: Tue Oct 03, 2017 11:04 am
by CalHusker
It was a clear case of dont know how to use it....

I got a reply from kiesel that states exactly what spudmunkey said....It is an also jack....

Thank you to the forum and Kiesel group.....Truly the easiest to play guitar I have ever played...