LB70 Club

Threads by Owners of Specific Kiesel Guitars / Carvin Guitars Instruments

Moderators: Kevio, ElfDude, JesseM, RockCrue, soundchick, ChrisH, peb, Mike Jones, Bundy

AzBloozBase
Newbie
Newbie
Posts: 13
Joined: May 2015

re: LB70 Club

Postby AzBloozBase » Sun Jun 07, 2015 7:28 pm

Ok all... here she isImage

LB75PJoe
Newbie
Newbie
Posts: 2
Joined: Feb 2018

Re: LB70 Club

Postby LB75PJoe » Sat Feb 10, 2018 7:24 pm

Update: Albert from Tech Support told me the active passive module from their kits would work without the Piezo. Turns out the pots don't all line up and I have a dummy pot in temporarily but the module still doesn't seem to work right. The mid and treb have zero effect and the bass seems to act more like a tone control than a cut or boost. I've removed and de-gunked the battery boxes but I think I am going to re-wire the module and battery boxes as my first soldering attempt is suspect.

CARVINs.JPG

This is before the repairs made to the LB75p

Hello fellow LBers. I am new to the forum but have owned an LB70p since 2009 and recently acquired a LB75p. Pictures will be coming shortly but I have a question: has anyone ever removed a battery (both basses are 18v) WITHOUT unplugging the bass? I did this past week on my LB75 and now the only way I get any output is on the "up/passive" mode. Am I screwed? Are there parts that I can change or aftermarket pre amps that will fit?
You do not have the required permissions to view the files attached to this post.
Last edited by LB75PJoe on Thu Mar 01, 2018 12:55 pm, edited 3 times in total.

User avatar
Praiser
Carvinite
Carvinite
Posts: 753
Joined: Jan 2007
Location: Kansas Flatland

Re: LB70 Club

Postby Praiser » Sun Feb 11, 2018 5:21 am

I've never done it, but many have, so don't feel too bad.
This is a known issue that the preamp blows if the battery is removed with the cable plugged in.

I'd recommend calling the factory to see if they still have any of the older preamps available.
You'll need to open the cavity and either take a pic or find the number printed on one of the circuit boards.
Alternately, I think the new 4 knob pre will fit into the older cavity as it has some flexibility, but I'm NOT certain.
You'll likely have an extra hole or 2 though. Getting the piezo in the bridge to work is the big challenge

Some folks just leave them passive and use just the volume and blend as they still sound great.
Me personally, I'd try to get a Carvin/Kiesel unit to put in there, but there are aftermarket pres that would work, too.
Again, the piezo is going to be the challenge....

One guy that had major electronics skills was able to repair his and add a circuit to prevent it from happening again.
No idea if that thread is still around as it was a few years back, but search here and at the CarvinMuseum website.

Best of luck, and let us know how it works out for you....and we really need pics of these basses. :wink:
John

LB75AP, LB70P, X54F, BK50, BK50F, BK40, C780
PB100, PB200 (With BX500 head and 1x15 ext Cab)
XP1000L, LM153s, LS1801A
Rogue Fretless, Ibanez ABG, Dobro Bass
Peavey Fury P Bass

User avatar
gumbynotpokey
Elite Carvinite
Elite Carvinite
Posts: 7390
Joined: May 2010
Location: Western NC

Re: LB70 Club

Postby gumbynotpokey » Sun Feb 11, 2018 11:53 am

Praiser wrote:I've never done it, but many have, so don't feel too bad.
This is a known issue that the preamp blows if the battery is removed with the cable plugged in.

I'd recommend calling the factory to see if they still have any of the older preamps available.
You'll need to open the cavity and either take a pic or find the number printed on one of the circuit boards.
Alternately, I think the new 4 knob pre will fit into the older cavity as it has some flexibility, but I'm NOT certain.
You'll likely have an extra hole or 2 though. Getting the piezo in the bridge to work is the big challenge

Some folks just leave them passive and use just the volume and blend as they still sound great.
Me personally, I'd try to get a Carvin/Kiesel unit to put in there, but there are aftermarket pres that would work, too.
Again, the piezo is going to be the challenge....

One guy that had major electronics skills was able to repair his and add a circuit to prevent it from happening again.
No idea if that thread is still around as it was a few years back, but search here and at the CarvinMuseum website.

Best of luck, and let us know how it works out for you....and we really need pics of these basses. :wink:


what he said

hi john!
Wife: C350, Claro top SH550, Vintage 16
Oldest: DC400M greenburst, C980TMW
Youngest: C750, GK1, CT624M Deep Black Cherry on flame, V3MC Celestion,
SH550 white/white, black binding, gold hardware
Me: LB70P jet black, LB70PF Claro BEM HAN, MB 10

LB75PJoe
Newbie
Newbie
Posts: 2
Joined: Feb 2018

Re: LB70 Club

Postby LB75PJoe » Mon Sep 10, 2018 6:51 am

Hey All...

I've had a friend go in and clean up my install mess... I suck with a soldering iron, not bad with a 9-iron, but suck with a soldering iron and still no tonal difference when in active mode from the treb and mid pots. The bass pot acts more like a tone control than anything else. I am comparing this to the functioning pre amp on my 4-string LB. The replacement is the 501 non piezo module sothe pots are arrange bass - treb - mid instead of the bass - mid - treb.

Is there any chance the module could be bad? My guy only wired it for 9-volt cause he read the 18-volters were more problematic on the 501 module. Any thoughts? I am tempted to ship it back to Carvin/Albert and let them go thru it for me at this point...

Joe

User avatar
ElfDude
Moderator
Moderator
Posts: 10644
Joined: Jan 2007
Location: In and around the lake

Re: LB70 Club

Postby ElfDude » Mon Sep 10, 2018 9:20 am

Does LB76 count for this club?

LB76F-indoors.jpg
You do not have the required permissions to view the files attached to this post.
Aries A6H, CS6M, SH445, Contour 66, AE185, DC135, CT4M, Bolt, SH225, LB76F, Nomad, VT16 Head, V410, Pro Bass 100
Midlife Crisis on Facebook
The Tri-Chevys on Facebook


Return to Guitar & Bass Clubs

Who is online

Users browsing this forum: No registered users and 1 guest