LB75 preamp low volume

General Technical Discussion

Moderators: Kevio, ElfDude, JesseM, RockCrue, soundchick, ChrisH, peb, Mike Jones, Bundy

rickenclacker
Newbie
Newbie
Posts: 2
Joined: Nov 2017

LB75 preamp low volume

Postby rickenclacker » Mon Nov 13, 2017 7:35 pm

I have a LB75 with active controls , circa 2002, (the 9v preamp). In the active mode, there is very little volume when the guitar volume knob is at full volume, can barely hear it through the speaker cabs, but there is sound, and the volume does adjust from zero to, well, lets say "1" on a volume scale of 1 to 10.
In passive mode, the volume functions normally, all the up to a glorious loudness of "10".

I have changed the battery, with no difference. Both alkaline and non-alkaline batteries.

Have twin humbucker at the bridge, J-style PU at the neck. THe toggle switch make no difference in the problem

Any suggestions to what the problem may be?

User avatar
Praiser
Carvinite
Carvinite
Posts: 704
Joined: Jan 2007
Location: Kansas Flatland

Re: LB75 preamp low volume

Postby Praiser » Tue Nov 14, 2017 7:20 am

That sounds like the olderish version of the preamp and I don't own that particular one.
All of mine are the 18v system. There are 2 things I'd look into though.

1. Unplug the cable, and open the control cavity and check for any loose wires or questionable solder joints. You could use a continuity tester to check individual circuits if you have one.
2. These preamps will die if the battery is changed while the cable is plugged into the bass. Not sure if the new ones are still like this, but I won't risk it on mine. It's a poor design feature in my mind, and has bit a number of folks through the years. When in doubt, remove the cable before doing anything, but it may be too late for yours if this is the case.

You might also try to spray some deoxit into the volume active/passive pot as it's marginally possible that it isn't making good contact in the down position.

Best of luck and please let us know what you find.
John

LB75AP, LB70P, X54F, BK50, BK50F, BK40, C780
PB100, PB200 (With BX500 head and 1x15 ext Cab)
XP1000L, LM153s, LS1801A
Rogue Fretless, Ibanez ABG, Dobro Bass
Peavey Fury P Bass

rickenclacker
Newbie
Newbie
Posts: 2
Joined: Nov 2017

Re: LB75 preamp low volume

Postby rickenclacker » Wed Nov 15, 2017 4:14 am

#2 is possible..I was diligent on unplugging the cable first when done playing to not wear the battery out,, but had not played this bass in a while.

I did not see any loose wires, but will follow your suggestion on testing.

Thanks for your comments


Return to Tech Talk

Who is online

Users browsing this forum: No registered users and 1 guest